Archive for October, 2009

Comme beaucoup, vous avez remarqué que depuis le passage de votre iPhone en version 3.x, le menu Données cellulaires n’est plus disponible. Ceci peut être ennuyeux dans certains cas comme le mien car à chaque restauration de mon iPhone le paramètre Nom du point d’accès (apn) est initialisé avec une valeur erronée. Voici un petit tutoriel qui explique comment activer le menu Données Cellulaire sur votre iPhone.

Prérequis :
– avoir un iPhone jailbroken (tutoriel pour jailbreak votre iPhone)
– avoir OpenSSH installé
– avoir un outil pour se connecter en scp sur votre iPhone (j’utilise Fugu sur Mac et Winscp sur Windows)
– avoir installé Plist Editor pour Windows

1. Première étape, connectez vous sur votre iPhone en utilisant Winscp ou Fugu pour Mac. Récupérez le fichier carrier.plist dans :

/System/Library/Carrier Bundles/XXX.bundle/carrier.plist

Pour les utilisateurs Mac :

2. Ouvrez le fichier en cliquant dessus et ajoutez l’entrée AllowEDGEEditing comme on peut le voir sur la copie d’écran.

apneditingmac

Pour les utilisateurs Windows :

2. Ouvrez le fichier carrier.plist avec Plist Editor et ajoutez les lignes suivantes :

edgeeditingwin

3. Sauvegardez les changements et copiez le fichier carrier.plist sur votre iPhone comme à l’étape 1.

4. Une fois terminé, vous pouvez éditer les paramètres de votre apn en allant dans le menu Réglages\Général\Réseau\Réseau de données cellulaires :

apn

Récemment j’ai été confronté à un problème de configuration sur un routeur Cisco 3845. L’objectif était simple, il fallait configurer du failover sur le routeur entre deux provider. D’un côté une ligne louée et de l’autre une connexion ADSL négociée à partir du routeur. Si l’énoncé semble simple, le résultat n’est pas pour autant évident (surtout pour un expert Cisco comme moi).

Le premier requis est d’avoir la bonne version d’IOS installé, en l’occurrence la fonctionnalité ip sla est disponible à partir de l’IOS 12.4 avec le feature set advanced IP services ou advanced security. Pour rappel, vous trouverez la procédure pour mettre à jour un IOS Cisco ici. Voici un petit schéma qui reprends l’énoncé précédent.

Cisco IP SLA

Cisco IP SLA

Voici la configuration nécessaire au bon fonctionnement de votre loadbalancing :

hostname Router_Name
!
ip cef
!
!#### Définir les objets de tracking. Ces objets sont utilisés pour ####!
!#### vérifier la disponibilité d’un host sur chaque ISP ####!
!
ip sla 1
icmp-echo 1.1.1.2 source-ip 1.1.1.1
frequency 30
ip sla schedule 1 start-time now life forever
!
ip sla 2
icmp-echo 2.2.2.3 source-ip 2.2.2.2
frequency 30
ip sla schedule 2 start-time now life forever
!
!#### Configurer les objets de tracking (cf. IP SLA) ####!
!
track 101 rtr 1 reachability
track 102 rtr 2 reachability
!
!#### Configuration des différentes interfaces ####!
!
interface GigabitEthernet0/0
description Internal connection
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
media-type rj45
no mop enabled
!
interface GigabitEthernet0/1
description ADSL connection
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
duplex auto
speed auto
media-type rj45
pppoe enable
pppoe-client dial-pool-number 1
no mop enabled
!
interface FastEthernet0/1/0
switchport access vlan 3
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Vlan3
description Lease Line
ip address 1.1.1.1 255.255.255.248
ip nat outside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip flow ingress
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1412
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username user password 5 5s454f654r64v4br5t4bvr4
!
!#### Définition des routes en fonction des objets de tracking ####!
!#### dans notre, nous avons une configuration de load balancing ####!
!#### mais on pourrait définir une priorité sur une route pour éviter le loadbalancing ####!
!
ip route 0.0.0.0 0.0.0.0 vlan3 track 101
ip route 0.0.0.0 0.0.0.0 dialer0 track 102
!
!#### Configurer le NAT pour le trafic entrant ####!
!
ip nat inside source route-map ISP1 interface vlan3 overload
ip nat inside source route-map ISP2 interface dialer0 overload
!
!#### Configuration du NAT pour du traffic VPN entrant ####!
!
ip nat inside source static udp 192.168.1.1 500 1.1.1.1 500 route-map ISP1 extendable
ip nat inside source static udp 192.168.1.1 500 2.2.2.2 500 route-map ISP2 extendable
ip nat inside source static 192.168.1.1 1.1.1.1 route-map ISP1 extendable
ip nat inside source static 192.168.1.1 2.2.2.2 route-map ISP2 extendable
!
!#### Configuration des route maps en référence à la configuration du NAT ####!
!
route-map ISP1 permit 100
match interface vlan3
!
route-map ISP2 permit 100
match interface dialer0
!

Sources :
http://www.blindhog.net/cisco-dual-internet-connections-without-bgp
http://hypergressive.blogspot.com/2009/03/dual-isp-load-balancing-configuration.html

Coup de coeur

Un petit post rapide pour parler de mes coups de cœur du moment.
A commencer par ce groupe de musique aux allures Punk qui, visiblement, ne fait rien pour soigner son image de marque : GOSSIP. En même temps avec une voix pareille il n’y a rien à regarder mais tout à écouter … Fondé en 1999, le groupe enchaîne les albums depuis … (7 albums en 9 ans). Actuellement, ils font un carton avec leur dernière chanson Heavy Cross.

GOSSIP

GOSSIP

Autre coup cœur, autre registre, il s’agit d’un vieux mp3 que j’ai défragmenté de mon NAS : After dark de Tito & Tarentula. Tout le monde se souvient encore du déhanché démoniaque de Salmah Hayek dans Une nuit en enfer sur cette musique. D’ailleurs la bande son du film contient un autre titre que j’aime beaucoup du groupe The Blasters: Dark knight


Une nuit en enfer

Une nuit en enfer

BMW Mobile Care

Mon concessionnaire BMW est vraiment sympa !

Ce matin en partant au boulot, je m’aperçois qu’un voyant jaune inhabituel s’allume sur le tableau de bord de la voiture, pourtant elle roule très bien. Soit, je pars en clientèle …
En sortant de mon client, le voyant étant toujours allumé, j’appelle le BMW Mobile Care qui me dit de me rendre chez mon concessionnaire au plus vite. Un rendez vous annulé je profite de l’occasion pour passer chez BMW. C’est assez drôle, car juste en donnant votre clé ils ont le listing détaillé de toutes les erreurs de la voiture. En l’occurrence, j’apprends que mes plaquettes de freins sont HS (33 000kms, cela fait peu mais bon). La personne ne veux pas me laisser repartir avec la voiture(trop dangereux), mais malheureusement, j’ai besoin d’une voiture. Elle me dit qu’elle va voir ce qu’elle peut faire. De là, elle revient et me demande si une BMW M3 ferait l’affaire. Petit moment d’hésitation, et je lui réponds calmement : “Oui, cela devrait aller.”

Update – 10/10/2009
Pour info, la bête développe 420cv avec son V8 …

Bon pour la suite, je vous laisse imaginer. Des images s’expriment toujours mieux que des mots :

Compte tours BMW M3

Compte tours BMW M3

M3 back

M3 back

BMW M3 front

BMW M3 front